[Gridflow-dev] osx loading prob

james tittle tigital at mac.com
Sun Mar 26 12:29:24 EST 2006

On Mar 23, 2006, at 1:46 PM, james tittle wrote:
> ...I just had the idea to use "install_name_tool" to change the
> gridflow.* linked library names to the 1.9 version, and get the
> following output in pd's console:
> tried /Users/tigital/Desktop/Pd-0.39.2-extended-test1.app/Contents/
> Resources/Scripts/../extra/zexy/gridflow.pd_darwin and failed
> tried /Users/tigital/puredataDev/gridflow/gridflow.pd_darwin and
> succeeded
> gridflow.pd_darwin found itself in /Users/tigital/puredataDev/gridflow
> we are using Ruby version 1.9.0
> (done)
> ERROR: Cannot load GridFlow-for-Ruby (gridflow.so)
> ...and then this is output in my debugging terminal:
> Pd version 0.39-1
> compiled 14:08:08 Nov  8 2005
> Pt_Start() called
> PDP: pure data packet
> PDP: version 0.12.4
> DIR = /Users/tigital/puredataDev/gridflow
> [LoadError] [no such file to load -- gridflow]:
> (eval):1:in `require'
> (eval):1

...I guess it's obvious that the following code bit is where the  
failure is:

	if (!
	EVAL("begin require 'gridflow'; true; rescue Exception => e;\
		STDERR.puts \"[#{e.class}] [#{e.message}]:\n#{e.backtrace.join'\n'} 
\"; false; end"))
		post("ERROR: Cannot load GridFlow-for-Ruby (gridflow.so)\n");

...since I'm getting "[LoadError]...", I'm guessing that the linked  
ruby 1.9 just can't find gridflow.so, even though it's in the same  
directory?  I don't know if this can be fixed by changing ruby, or  
maybe doing "begin require './gridflow'..."?

not a ruby expert,

More information about the Gridflow-dev mailing list