[Gridflow-dev] osx loading prob

james tittle tigital at mac.com
Thu Mar 23 13:46:14 EST 2006

...ok, so we can compile gridflow on osx now, but can we use it?  Not  
yet...in my last email, gridflow was getting dynamicly linked with  
the fink-installed ruby 1.8:  ostensibly, that was the cause of it  
not loading...

...I just had the idea to use "install_name_tool" to change the  
gridflow.* linked library names to the 1.9 version, and get the  
following output in pd's console:

tried /Users/tigital/Desktop/Pd-0.39.2-extended-test1.app/Contents/ 
Resources/Scripts/../extra/zexy/gridflow.pd_darwin and failed
tried /Users/tigital/puredataDev/gridflow/gridflow.pd_darwin and  
gridflow.pd_darwin found itself in /Users/tigital/puredataDev/gridflow
we are using Ruby version 1.9.0
ERROR: Cannot load GridFlow-for-Ruby (gridflow.so)

...and then this is output in my debugging terminal:

Pd version 0.39-1
compiled 14:08:08 Nov  8 2005
Pt_Start() called
PDP: pure data packet
PDP: version 0.12.4
DIR = /Users/tigital/puredataDev/gridflow
[LoadError] [no such file to load -- gridflow]:
(eval):1:in `require'

...seems like this is some progress, but what is this telling me, or  
better yet, any idea where to go from here?


More information about the Gridflow-dev mailing list