[Gridflow-dev] can't compile with Gem support

Mathieu Bouchard matju at artengine.ca
Thu Oct 15 17:28:56 EDT 2009

On Thu, 15 Oct 2009, gnd at itchybit.org wrote:

> tried to compile this revision, and it works for me (configure finds 
> gem09, compiles ok) i do: ./configure --gem-include 
> /root/src/gem-0.92-1/src/ ^^ i point to compiled gem sources directory
> maybe thats the problem ?

Sorry, my previous answer probably wasn't any related to the problem at 
all! (argh)

Well, on my machine, I do use this: 

and it already worked before the changes I made today, so I don't know 
what could not work. Permissions are ok, and everything?...

On my system it looks like:
g++ -I/usr/local/include -I. -xc++ -fno-operator-names 
-I/usr/X11R6/include -fmessage-length=150 -O3 
-I/home/matju/src/gem-0.92-1/src -mtune=pentium -march=pentium -Wall 
-Wno-unused -Wunused-variable -g -fPIC -I. -c optional/gem.c.fcs -o 

>> format/quicktimehw.c.fcs: In member function ‘void
>> FormatQuickTimeHW::constructor(t_symbol*, int, t_atom2*, t_symbol*,
>> string)’:
>> format/quicktimehw.c.fcs:49: warning: deprecated conversion from string
>> constant to ‘char*’

This is completely irrelevant and I have no idea why it appears at this 
point in your log...

>> optional/gem.c.fcs:28: error: expected class-name before ‘{’ token

This and any further errors are caused by the «No such file or directory» 

  _ _ __ ___ _____ ________ _____________ _____________________ ...
| Mathieu Bouchard, Montréal, Québec. téléphone: +1.514.383.3801

More information about the Gridflow-dev mailing list