[Gridflow-dev] dc1394 camera problem

Mathieu Bouchard matju at artengine.ca
Mon Nov 16 20:12:49 EST 2009

On Mon, 16 Nov 2009, gnd at itchybit.org wrote:

> #camera.pd shouldn't bang [args] anymore.


> DC1394: hello world
> there are 1 Feuerweuer ports
> trying port #0...
> port #0 has 0 cameras
> error: [#io.dc1394 in]: no cameras available

that is because you do not have a DC camera plugged in.

> [26994.600762] ieee1394: raw1394: /dev/raw1394 device initialized
> [26994.608221] NOTE: The dv1394 driver is unsupported and may be removed
> in a future Linux release. Use raw1394 instead.

this is because you plugged a DV (AVC) camera in... perhaps. Well, I would 
say that it is because you tried opening it in GEM, because with GridFlow, 
this camera is not seen at all.

> I can grab video from the camera via dvgrab.

That is because you are using a DV camera and not a DC camera.

> What is strange is that i cant access the video via GEM also (no matter 
> what i tried) ..

GEM does have DV code, and I tried transplanting it into GridFlow a long 
time ago (2005?), and it would freeze the complete computer. This may have 
to do with why the «dv1394» driver is deprecated. Other software might be 
using this driver or a newer one. I don't know about dvgrab.

Can you get that camera to be opened by any V4L2 application?

  _ _ __ ___ _____ ________ _____________ _____________________ ...
| Mathieu Bouchard, Montréal, Québec. téléphone: +1.514.383.3801

More information about the Gridflow-dev mailing list