[Gridflow-dev] [PD-announce] GridFlow 0.9.1

marius schebella marius.schebella at gmail.com
Mon Apr 28 00:13:02 EDT 2008

Mathieu Bouchard wrote:
> On Sat, 26 Apr 2008, marius schebella wrote:
>> I gave it another try and added a flag -msse (although I am not really 
>> sure what I was doing) and got rid of the error, but not of errors in 
>> general,
> The important part is to get rid of errors that I don't know how to fix, 
> because I fixed the rest. This is because GridFlow changes internally 
> and so I have to change OSX-specific source code that I can't test and 
> sometimes I make mistakes, for example. (It's not just that, though, but 
> anyway, what I said I fixed, you don't need to take care of: just switch 
> to a more recent GridFlow to get my new fixes)
>> are there sse instructions in the code and I have to explicitely pass 
>> -msse??
> Not in GridFlow's code. There is a MMX1 (really!) module that is 
> "compiled" separately and is only enabled if you have NASM. However, in 
> OSX's headers, there might be SSE-specific declarations and I can't do 
> anything about that.
>> Can you check my compile flags and see if they are correct? I wonder 
>> if the -mtune=pentium and -march=pentium are correct at all? maybe 
>> config discovered a wrong architecture? is intel chip pentium compatible?
> If I read correctly: all Intel Macs use processors that are direct 
> descendents of "Pentium M" and "Pentium D" processors, and those 
> descendents are also what gets sold as part of today's PC computers. All 
> those CPUs are apparently fundamentally part of the same family as 
> "Pentium Pro", which dates back to 1995 or so, but the 
> backward-compatibility of executable files may go back as far as 
> programs compiled in 1978 (if 16-bit mode is supported by the OS).
>> /System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/MachineExceptions.h:217: 
>> error: ?__m128i? does not name a type
>> /System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/MachineExceptions.h:218: 
>> error: ?__m128d? does not name a type
> I still don't know what those are. Look like they might be meaning 
> "128-bit integer" and "128-bit float" respectively, but that's just a 
> wild guess, and it doesn't give us any hint on how to fix it.

hi matju.
I found only one page on google that was showing the same error, and 
according to it, I tried to change -mtune and -march to k8 (which again 
is just a guess)
I tried with revision 3678, but still get erros.

nyc-calling:trunk marius$ g++ 
-I/Users/marius/devel/pd-rsync/pd-extended/pd/src -I/sw/include 
-I/usr/local/include -I/Users/marius/include -I. -xc++ 
-fno-operator-names -fno-omit-frame-pointer -I/usr/X11R6/include 
-falign-functions=16 -mtune=k8 -march=k8 -DMACOSX -Wall -Wno-unused 
-Wunused-variable -g -fPIC -I. -O2 -funroll-loops -xobjective-c++ -c 
format/quartz.m.fcs -o format/quartz.o
format/quartz.m.fcs: In function ‘int -[GFView imageHeight](GFView*, 
format/quartz.m.fcs:58: warning: conflicting types for ‘-(int)imageHeight’
format/quartz.m.fcs:48: warning: previous declaration of ‘-(id)imageHeight’
format/quartz.m.fcs: In function ‘int -[GFView imageWidth](GFView*, 
format/quartz.m.fcs:59: warning: conflicting types for ‘-(int)imageWidth’
format/quartz.m.fcs:49: warning: previous declaration of ‘-(id)imageWidth’
format/quartz.m.fcs: In function ‘void GFView_display(GFView*)’:
format/quartz.m.fcs:111: error: cannot convert ‘objc_object*’ to 
‘CGFloat’ in initialization
format/quartz.m.fcs:111: error: cannot convert ‘objc_object*’ to 
‘CGFloat’ in initialization
format/quartz.m.fcs: In member function ‘void 
FormatQuartz::constructor(t_symbol*, int, t_atom2*, t_symbol*)’:
format/quartz.m.fcs:135: error: ‘FormatQuartz_call’ was not declared in 
this scope
format/quartz.m.fcs: In function ‘void FormatQuartz_startup(FClass*)’:
format/quartz.m.fcs:213: warning: unused variable ‘pool’

More information about the Gridflow-dev mailing list