[Gridflow-cvs] [svn] commit: r6466 - /trunk/src/classes1.cxx

svn-gridflow at artengine.ca svn-gridflow at artengine.ca
Tue Jan 11 15:19:52 EST 2011


Author: matju
Date: Tue Jan 11 15:19:52 2011
New Revision: 6466

Log:
revert a previous change in [#import] about cast type. This will have to be changed further, in the future, to support two currently conflicting features.

Modified:
    trunk/src/classes1.cxx

Modified: trunk/src/classes1.cxx
==============================================================================
--- trunk/src/classes1.cxx (original)
+++ trunk/src/classes1.cxx Tue Jan 11 15:19:52 2011
@@ -119,7 +119,13 @@
 		if (!in[0]) in[0]=new GridInlet((FObject *)this,stromgol);
 		while (n) {
 			if (!go || !go->sender) {
-				if (per_message) go = new GridOut(this,0,in[0]->dim,in[0]->nt);
+				// the cast of per_message was changed twice, because of [hpgl_font_render]
+				// and because of something else. This suggests that there is a problem about
+				// what [#import] is expected to do in per_message mode. This could lead to a
+				// special default value of cast that wouldn't be a NumberType but instead would
+				// be "copy" or "from_message" or some similar name. But is that what we want
+				// to be using as a default instead of cast i, even when #import is not per_message ?
+				if (per_message) go = new GridOut(this,0,in[0]->dim,     cast /*in[0]->nt*/);
 				else             go = new GridOut(this,0,       dim,     cast);
 			}
 			long n2 = min((long)n,go->dim.prod()-go->dex);



More information about the Gridflow-cvs mailing list