[Gridflow-cvs] [svn] commit: r6609 - in /trunk: ChangeLog TODO

svn-gridflow at artengine.ca svn-gridflow at artengine.ca
Wed Feb 16 21:11:50 EST 2011


Author: matju
Date: Wed Feb 16 21:11:49 2011
New Revision: 6609

Log:
...

Modified:
    trunk/ChangeLog
    trunk/TODO

Modified: trunk/ChangeLog
==============================================================================
--- trunk/ChangeLog (original)
+++ trunk/ChangeLog Wed Feb 16 21:11:49 2011
@@ -7,6 +7,8 @@
  * [#to~]: report "buffer full" at most once per incoming grid.
  * [#from]: fix crash upon deleting object
  * [#from]: add second argument for buffer size (in samples)
+ * [#see]: experimental version goes about 5 times faster. (use [#see 1])
+ * [#draw_polygon]: added "rule winding" and "rule multi"
 
 version 9.13 (2011.02.08):
 
@@ -15,6 +17,13 @@
  * [#expr]: added functions "if", "pow" (numop ** aliased to pow)
  * numop1: added fact (factorial or "gamma function" which is not [# gamma])
  * numop1: added log2, log10, C.log2, C.log10, unary+
+ * numop1: aliased log and C.log to ln and C.ln
+ * numop1: added asin acos atan asinh acosh atanh
+ * [#]: don't check type of right-grid when one-input operator
+ * [#]: fix one-input vecop support (complex numbers)
+ * [#]: don't ask for N elements in right inlet for a one-input operator
+ * [#expr]: fixed several parsing bugs
+ * numop2 weight becomes a numop1 (single inlet)
  * x11 is now a load-time option
  * [#io.x11]: added methods 'query_pointer' and 'out_size_minimum'
  * [route3]: fixed right outlet bug
@@ -26,17 +35,10 @@
  * [#in] and [#out]: in case of unknown suffix, say 'not open' afterwards
  * [#redim]: argument defaults to ()
  * former numop "atan" renamed to "atan2cd"
- * new numops: asin acos atan asinh acosh atanh
- * numops log and C.log aliased to ln and C.ln
  * [#inner] and [#convolve]: add seedless mode (without typecheck annoyance)
  * [unix_time]: fixed the month number bug
  * [#fold]: much faster in the case folding over a dim that has only 1 index
  * some more work on the Win32 port
- * [#]: don't check type of right-grid when one-input operator
- * [#]: fix one-input vecop support (complex numbers)
- * [#]: don't ask for N elements in right inlet for a one-input operator
- * [#expr]: fixed several parsing bugs
- * two-input numop "weight" becomes a one-input numop
  * [#from_pix]: much faster rgba->rgba conversion
  * [#from_pix]: added conversion to colorspace y
  * [#from_pix]: added conversion from [pix_grey] mode

Modified: trunk/TODO
==============================================================================
--- trunk/TODO (original)
+++ trunk/TODO Wed Feb 16 21:11:49 2011
@@ -1,28 +1,27 @@
 Unsorted
 
-[ ] do domain name transfer
+[ ] [args] loadbang order really, really sucks.
 [ ] [gf/error] can't take a list. (see [#is])
 [ ] mmx not properly detected anymore (bug in ruby ?)
 [ ] [#rzero_space]
-[ ] rename [#lop_space] to [#rpole_space] ?
-[ ] [#convolve]: remove "a" ?
 [ ] fix grid attribute setters
 [ ] list-attrs
 [ ] multi-valued attributes in source_filter
+[ ] <pob> matju: [hidecursor( marche aussi dans windows contrairement à ce que dit le fichier d'aide.
+[ ] <pob> matju: Dans l'index [#to~] apparaît comme hyperlien et non comme objet. Je ne sais pas si c'est volontaire.
+[ ] <pob> matju: dans le fichier d'aide de [#posterize] il y a deux [#out window] du coup l'image traitée n'est pas
+    affichée. Il n'y a qu'un fenêtre de crée (nommée 'modified') mais c'est l'image d'origine qui y est affichée.
 [ ] reform GFDP so that pd43 and l2ork become debuggable.
-[ ] in [#convolve]'s muladd, use a+b*(-1) = a-b
 [ ] note-help : something wrong with speedlim ? ask patrice (see courriel 7 nov 2010)
 [ ] memalign still doesn't exist on OSX and Windows ?
 [ ] reverify gem.cxx on OSX Intel-vs-PPC. Did I see a problem with 3 channels again ?
 [ ] "seedless" should be really skipping over the seed. but this didn't improve speed for [#fold].
-    so, I didn't continue the job on [#scan] [#inner] [#convolve] (note that [#inner] already a special case related to that)
+    so, I didn't continue the job on [#scan] [#inner] (note that [#inner] already a special case related to that)
 [ ] [#see] shm : http://wiki.tcl.tk/2999
 [ ] [gf/mouse_spy] bug with ... was it gop ? (didn't finish writing this line)
 [ ] #background_model plante
 [ ] rajouter les nouvelles patchs de Roman
 [ ] option to disable input when in edit-mode, for [#see] and [gf/mouse_spy]
-[ ] [#from~]: pick your own blocksize (default = use same as pd)
-[ ] fix warnings in config.log on OSX
 [ ] [#expr] local
 [ ] more [#expr] : int rint imodf modf drem fmod size sum Sum
 [ ] [fps] doesn't complain about invalid mode name
@@ -121,6 +120,7 @@
 [ ] [route] - 1[shunt] sends a message (bug)
 [ ] on n'a pas un vrai [getargs] au niveau du binbuf (ce qui, en soi, n'est pas évident)
     et ça va être compliqué d'éditer les args pour y rajouter vraiment ce qu'on veut.
+    (qu'est-ce qu'on fait avec les virgules ?)
 [ ] movie api : merge "height" & "width" attributes
 [ ] gridflow_gem*.pd_linux : missing error message on load (sometimes) because of sys_load_lib
 [ ] [#saturation] is a linear colorspace transform: therefore it could be accelerated just like [#hueshift] could.
@@ -205,6 +205,9 @@
 [ ] cellular_1d.pd: should get a variable width
 [ ] [#in unicap] and/or [#in videojack] ?
 [ ] [#draw_polygon] : some more weirdnesses in rendering. play a bit with #draw_polygon-test2.pd to see.
+[ ] fix warnings in config.log on OSX
+[ ] [#find]
+[ ] http://claudiusmaximus.goto10.org/cm/2010-12-15_histogram_equalization.html
 
 OpenCV
 [ ] cvOpticalFlow



More information about the Gridflow-cvs mailing list