[Lab] Arduino env hogging CPU?

Justin Slootsky justin at slootsky.org
Tue Jun 7 07:56:52 EDT 2016

Recently, my Arduino IDE has started hogging the CPU.  (I'm running 
windows 8.1)

I was running 1.6.8, and I just tried 1.6.9 and it does the same thing.

Task Manager shows javaw.exe at about 35% (when I'm not compiling or 
doing anything), and the IDE is very laggy, barely responding to mouse 

If I set the affinity to one or two (of my four) CPUs, then I don't lose 
control of my entire system, but the IDE is still really difficult to 
work in, and compilation takes a ridiculously long time.

When I start the IDE, there is  short period of time before the CPU 
becomes a hog.

I tried running arduino-debug to see if it showed anything, and I don't 
think so.  I see "Using proxy DIRECT" in the output.

I tried removing my line from 'Additional Boards Manager URLs', in case 
it was something there that was interfering (to no effect)

My googlefu has failed.

Any ideas?

More information about the Lab mailing list